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This article applies to: ML v7, ML8, MultiStore

An entry with the same key already exists.


Symptoms
The site throws a "An entry with the same key already exists" message when attempting to access the home page.

Cause
This is caused by a duplicate AppConfig

Solution
Make a complete backup of the storefront DB, then run the following SQL query against your DB to find the offending AppConfig:

SELECT [Name] FROM aspdnsf_AppConfig
GROUP BY [Name]
HAVING COUNT(*) > 1

Then run the following:

SELECT * FROM aspdnsf_AppConfig WHERE [Name] = 'name of duplicate AppConfig'

Delete any duplicate rows returned and repeat for each duplicate AppConfig.  Restart the site and it should be all set.