Looking for the v10 manual? Visit our new user's guide!
 
Search Descriptions Version
 
 
This article applies to: MultiStore

Error on entity pages after Excel Import


Symptoms
After performing an Excel Product Import, any entities created by the import will throw an error on the storefront and the exception in the System Log reads: "Error in XmlPackage(.Load), Package=[entity.DNE.xml.config], Msg=[The XmlPackage file could not be found..."

Cause
The Excel Import is not populating the XmlPackage field for the newly created entities, and MSx9300 is requiring one.

Solution
After running the Excel Product Import Tool, Edit and Save and Close each of the newly created entities, modifying the Display Format XmlPackage if desired. This will establish the Display Format XmlPackage and allow the entity to be viewed on the storefront.

Alternatively, you may run the following SQL queries against the database in your Configuration - Advanced - Run SQL window, replacing the 'entity.grid.xml.config' with a different package if desired (be sure to 'Reset Cache' after submitting these queries):

    UPDATE Category
    SET XMLPackage='entity.grid.xml.config'
    WHERE XMLPackage Is NULL
    UPDATE Section
    SET XMLPackage='entity.grid.xml.config'
    WHERE XMLPackage Is NULL
    UPDATE Manufacturer
    SET XMLPackage='entity.grid.xml.config'
    WHERE XMLPackage Is NULL