Symptoms
When Google Checkout has been properly set up, using Google Checkout goes to a blank page with the line 'Object moved to
here', and selecting the link returns the customer back to the cart page.
Cause
The Store Currency value in the Configuration >
Site Configuration Wizard must match the merchant account location, OR the credentials for the Google Checkout are incorrect.
Solution
Set the Store Currency to the appropriate value for the merchant location: USD for US merchant accounts, or GBP for UK merchants.
If this is correct and the issue is still occurring, verify your Google Checkout credentials are correct and in the proper AppConfigs.