This article applies to:
ML v7, ML8, MultiStore
Order Declined, Please Contact Customer Service
|
|
Symptoms
Customers encounter this error when clicking the Place Order button.
Cause
This is caused by a customer exceeding the failed transaction threshold set for the site. It is a security feature that prevents a malicious user (or script) from continually attempting fraudulent transactions to find a valid combination. This behavior is by design.
Solution
By default the store blocks any user who attempts 5 invalid transactions in a 30 minute period, and retains that block for a period of 30 days. If you need to modify this due to testing or business requirements, you have 2 options:
Change the Threshold
To change the number of failed transactions allowed before the account is locked, you can modify the IPAddress.MaxFailedTransactions AppConfig, then reset the cache.
Clear the Failed Transaction History
This will clear out any prior failed transactions and effectively reset the count to 0, unblocking any blocked accounts. To do this, first make a full backup of your DB, then run this script against the database. Remember that this table could contain important information, so it is a good idea to review the table before clearing it.
DELETE FROM [FailedTransaction]
|