This article applies to:
ML v7, ML8, MultiStore
Adding an Item to the Cart Results in an Empty Cart
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Symptoms
After clicking the Add To Cart button the site redirects to shoppingcart.aspx, however the cart remains empty
Cause
The most common cause for this issue is an application pool reset due to insufficient memory being allotted to the application pool. Under many shared hosting platforms, hosts place strict limits on the amount of memory that can be used by web applications being hosted on the server. The Add To Cart operation is responsible for a variety of tasks that take additional system resource, therefore if the site is running just below the memory limits set on the application pool, this operation is often enough to push the site beyond that limitation and cause the application pool to recycle.
Solution
The Application Event Log on the web server should have a record of application pool resets. It should be possible to correllate logged application pool resets to shoppingcart activities. Even if events are not logged, AspDotNetStorefront recommends a minimum application pool allowance of 125MB for reliable operation of AspDotNetStorefront. Larger site (those containing many products and entities, or site that receive large numbers of visitors over short time periods) may require considerably more memory. Users should contact their hosting provider or IT staff to determine if the environment can be made suitable to host the website.
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