This article applies to:
ML v7, ML8, MultiStore
Orders Listed In Failed Transactions On The Admin Site, But Show As Authorized On The Gateway Site When Using Authorize.Net
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Symptoms
When using Authorize.Net as the gateway, some orders are placed in the failed transaction log but show as authorized or captured on the Authorize.Net website or in your transaction reports.
Cause
This is caused by Authorize.Net’s risk management services marking the order for review. AspDotNetStorefront is not compatible with their Risk Management Services, and therefore an transaction that is received that does not contain a response code of 1 (approved) will be marked as a failed transaction and the order will not be completed. An order that is marked for review by Authorize.Net returns a response code of 4, which is seen as a failure.
Solution
To avoid potential duplicate charges or authorizations, AspDotNetStorefront recommends disabling the Risk Management Services on your Authorize.Net account. Our recommendations for eliminating fraud include implementing the MaxMind anti-fraud service and manually reviewing each transaction before capturing payment or shipping product to the customer. AspDotNetStorefront can also be configured to fail transactions that reach certain fraud risk threshold based on the MaxMind score. By using MaxMind, you receive the benefits of fraud protection while having full integration with AspDotNetStorefront’s admin site.
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