Symptoms
I have duplicate orders for customers who pay with PayPal Standard.
Cause
This is caused by a customer returning to your store from the PayPal site before the Instant Payment Notification call is received. The storefront creates an order record when the customer returns, and then another when the IPN comes in.
Solution
To avoid this, customers using PayPal’s IPN service should change the PayPal.ReturnOKURL AppConfig to a custom topic page that complies with PayPal's terms and conditions such as pps_return.aspx instead of paypalok.aspx. This will direct the customer back to your site without creating an order record that will duplicate the IPN one, and the customer will still get their emails from PayPal and your store.
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