This article applies to: ML v7, ML8, MultiStore

There is no registered user with that e-mail address


Symptoms
When a user attempts to log into the website, they receive a message stating that There is no registered user with that e-mail address, however you can locate the email account via the admin site user management page.

Cause
This is caused by a customer trying to log in with an account which was created during an anonymous checkout process, such as using Google Checkout, or skipping registration during the normal checkout process.

Solution
The customer would need to register a new account on the site, or the existing account may be updated to registered status by issuing a query directly against the database.

Caution:  Make a full backup of your site and database before issuing any adhoc queries against the database.

To set the account to registered, go to Admin --> Misc --> More --> Run SQL, and issue the following statement in the textbox:

UPDATE Customer SET IsRegistered = 1 WHERE Email = 'email of customer you need to update'

(example: UPDATE Customer SET IsRegistered = 1 WHERE Email = 'joe@customer.com')

After submitted the query and getting a successful response, have a new password sent to the customer's email address.