Symptoms
VAT information (pricing, special labels, etc) does not display for customers who are not logged in. Once they sign in, the VAT information displays fine.
Cause
This is caused by not having a valid country ID in the VAT.CountryID AppConfig. If that is not populated, the software cannot know which country to display information for until the customer logs in.
Solution
Populate the VAT.CountryID AppConfig with a valid country code.